aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-c2hs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-c2hs/Makefile')
-rw-r--r--devel/hs-c2hs/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index ea0c40a07f3b..0e65af558ce1 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= c2hs
-PORTVERSION= 0.10.15
+PORTVERSION= 0.10.16
CATEGORIES= devel
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
PKGNAMEPREFIX= hs-
@@ -19,10 +19,22 @@ RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
HAS_CONFIGURE= yes
USE_GMAKE= yes
+PLIST_SUB= C2HS_VERSION=${PORTVERSION}
+
CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-add-package
+.if defined(WITH_PROFILE)
+CONFIGURE_ARGS+= --enable-prof
+.endif
+
MAN1= c2hs-config.1 c2hs.1
+.if !defined(WITH_PROFILE)
+pre-everything::
+ @${ECHO_CMD} "To enable profiling support define WITH_PROFILE."
+ @${ECHO_CMD} "This requires ghc with profiling libraries."
+.endif
+
post-build:
@(cd ${WRKSRC}/doc/c2hs && ${GMAKE} man1/c2hs-config.1 man1/c2hs.1)