aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-utf8-string
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-utf8-string')
-rw-r--r--devel/hs-utf8-string/Makefile62
-rw-r--r--devel/hs-utf8-string/distinfo6
-rw-r--r--devel/hs-utf8-string/pkg-descr8
-rw-r--r--devel/hs-utf8-string/pkg-plist47
4 files changed, 76 insertions, 47 deletions
diff --git a/devel/hs-utf8-string/Makefile b/devel/hs-utf8-string/Makefile
index 11ac8b19b71d..840dcfee7823 100644
--- a/devel/hs-utf8-string/Makefile
+++ b/devel/hs-utf8-string/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= utf8-string
-PORTVERSION= 0.3.4
+PORTVERSION= 0.3.5
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -18,37 +18,59 @@ COMMENT= Support for reading/writing UTF8 strings for Haskell programs
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
-CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
-GHC_VERSION= 6.8.3
-SUBDIR= lib/${PORTNAME}-${PORTVERSION}
-PLIST_SUB+= GHC_VERSION=${GHC_VERSION} \
- PORTVERSION=${PORTVERSION} \
- PORTNAME=${PORTNAME} \
- SUBDIR=lib/ghc-${GHC_VERSION}/cabal
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-PORTDOCS= LICENSE html
+GHC_VERSION= 6.10.4
+UTF8STR_VERSION= ${PORTVERSION}
-CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} --libsubdir='' --datasubdir=''
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+UTF8STR_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ UTF8STR_VERSION=${UTF8STR_VERSION} \
+ UTF8STR_LIBDIR_REL=${UTF8STR_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.else
-PLIST_DIRS+= %%DOCSDIR%%
-PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${CABALCMD} haddock
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
.endif
do-install:
- cd ${WRKSRC} && ${CABALCMD} install \
- && ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${CABALDIR}/${PORTNAME}-register.sh
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${UTF8STR_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.include <bsd.port.mk>
diff --git a/devel/hs-utf8-string/distinfo b/devel/hs-utf8-string/distinfo
index 85d6c5076db1..e8f11ef97472 100644
--- a/devel/hs-utf8-string/distinfo
+++ b/devel/hs-utf8-string/distinfo
@@ -1,3 +1,3 @@
-MD5 (utf8-string-0.3.4.tar.gz) = 72d13d9453cdf721dd95bc18144a120a
-SHA256 (utf8-string-0.3.4.tar.gz) = f97027354f0b88af9bf3638aee0eb3bb72c05ec44f4af4c1abe070597059a5bd
-SIZE (utf8-string-0.3.4.tar.gz) = 8063
+MD5 (utf8-string-0.3.5.tar.gz) = d5198209bd81ea4f8af7692e2467336c
+SHA256 (utf8-string-0.3.5.tar.gz) = 41f99b3e9f61ab5309c93f98d45f1ba2e475a8504c5202a350720c27fb82d07a
+SIZE (utf8-string-0.3.5.tar.gz) = 8758
diff --git a/devel/hs-utf8-string/pkg-descr b/devel/hs-utf8-string/pkg-descr
index 2a19919f8879..52a189edfd36 100644
--- a/devel/hs-utf8-string/pkg-descr
+++ b/devel/hs-utf8-string/pkg-descr
@@ -1,5 +1,5 @@
-A UTF8 layer for IO and Strings. The utf8-string package
-provides operations for encoding UTF8 strings to Word8 lists
-and back, and for reading and writing UTF8 without truncation.
+A UTF8 layer for IO and Strings. The utf8-string package provides operations for
+encoding UTF8 strings to Word8 lists and back, and for reading and writing UTF8
+without truncation.
-WWW: http://github.com/glguy/utf8-string/
+WWW: http://github.com/glguy/utf8-string/
diff --git a/devel/hs-utf8-string/pkg-plist b/devel/hs-utf8-string/pkg-plist
index 1dc9435721bb..ccda5fa99128 100644
--- a/devel/hs-utf8-string/pkg-plist
+++ b/devel/hs-utf8-string/pkg-plist
@@ -1,22 +1,29 @@
-%%SUBDIR%%/Codec/Binary/UTF8/Generic.hi
-%%SUBDIR%%/Codec/Binary/UTF8/String.hi
-%%SUBDIR%%/Data/ByteString/Lazy/UTF8.hi
-%%SUBDIR%%/Data/ByteString/UTF8.hi
-%%SUBDIR%%/Data/String/UTF8.hi
-%%SUBDIR%%/System/IO/UTF8.hi
-%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%SUBDIR%%/%%PORTNAME%%-register.sh
-@dirrmtry %%SUBDIR%%/System/IO
-@dirrmtry %%SUBDIR%%/System
-@dirrmtry %%SUBDIR%%/Data/String
-@dirrmtry %%SUBDIR%%/Data/ByteString/Lazy
-@dirrmtry %%SUBDIR%%/Data/ByteString
-@dirrmtry %%SUBDIR%%/Data
-@dirrmtry %%SUBDIR%%/Codec/Binary/UTF8
-@dirrmtry %%SUBDIR%%/Codec/Binary
-@dirrmtry %%SUBDIR%%/Codec
-@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@comment $FreeBSD$
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8/Generic.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8/String.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/ByteString/Lazy/UTF8.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/ByteString/UTF8.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/String/UTF8.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSutf8-string-%%UTF8STR_VERSION%%.o
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Environment/UTF8.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/IO/UTF8.hi
+%%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSutf8-string-%%UTF8STR_VERSION%%.a
+%%UTF8STR_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/IO
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Environment
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/String
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/ByteString/Lazy
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/ByteString
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Codec/Binary
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Codec
+@dirrm %%UTF8STR_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%UTF8STR_LIBDIR_REL%%
+@exec /bin/sh %D/%%UTF8STR_LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%
+@unexec %D/bin/ghc-pkg unregister utf8-string
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old