aboutsummaryrefslogtreecommitdiffstats
path: root/devel/icmake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/icmake/Makefile')
-rw-r--r--devel/icmake/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/icmake/Makefile b/devel/icmake/Makefile
index 5042100c6bb3..71b9b28f387c 100644
--- a/devel/icmake/Makefile
+++ b/devel/icmake/Makefile
@@ -29,6 +29,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
REINPLACE_ARGS= -I ""
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash|' \
${WRKSRC}/icm_bootstrap \
@@ -103,7 +105,7 @@ do-install:
.if !defined(NO_INSTALL_MANPAGES)
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install man
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install doc
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install docdoc
.endif