aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdesdk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kdesdk/Makefile')
-rw-r--r--devel/kdesdk/Makefile23
1 files changed, 22 insertions, 1 deletions
diff --git a/devel/kdesdk/Makefile b/devel/kdesdk/Makefile
index 520bb4d9af75..4a70fd498429 100644
--- a/devel/kdesdk/Makefile
+++ b/devel/kdesdk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdesdk
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,15 +14,36 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
USE_KDEBASE_VER=2
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde2
MAN1= cvs2pack.1 cvschanged.1 cvsversion.1 noncvslist.1 kde-build.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>
ss='deletions'>-1/+0 * Unbreak INDEX by removing deprecated py31-tkinterantoine2014-03-071-1/+0 * KDE/FreeBSD team is happy to present Qt 5 in ports!makc2014-03-041-0/+4 * Replaced by x11-toolkits/uniquebapt2014-02-251-1/+0 * Remove: broken rendering, abandoware, build system not stage readybapt2014-02-251-1/+0 * Remove the toolkit is unused in the ports tree and abandonned upstream for ar...bapt2014-02-241-1/+0 * - Moved to a better categorydanilo2014-02-161-1/+0 * Granite is an extension of Gtk+ toolkit. It provides several widgets andolivierd2014-02-111-0/+1 * - Keep category Makefiles sortedamdmi32014-01-281-1/+1 * New port: x11-toolkits/wxgtk30 -- Series 3.0 of the wxWidgets toolkitgahr2014-01-221-0/+1 * - Remove some outdated Haskell portspgj2014-01-101-1/+0 * In preparation for Qt 5 ports:makc2014-01-071-0/+1 * Remove expired ports:rene2013-12-211-1/+0 * Add vte3, the Gtk 3 version of the vte terminal widget.kwm2013-12-081-0/+2 * Remove expired ports:rene2013-12-011-1/+0 * Say hello to Mate 1.6.kwm2013-11-231-0/+1 * Remove old *gnome*mm libraries not in used in the ports tree.bapt2013-11-181-1/+0 * - New port: x11-toolkits/fltk-develgahr2013-10-241-0/+1 * 2013-10-21 devel/rubygem-ruby-debug-base: Does not work with Ruby 1.9tabthorpe2013-10-221-1/+0 * 2013-10-10 x11-toolkits/ruby-tk: Does not work with Ruby 1.9tabthorpe2013-10-161-1/+0 * Remove some ports depending on gnome1bapt2013-10-071-1/+0 * Remove the EOLed x11-toolkits/guile-gtk (gnome1) and its latest userbapt2013-10-051-1/+0 * Remove expired ports:rene2013-09-011-1/+0 * - Disconnect ports removed in r325546bdrewery2013-08-291-5/+0 * The FreeBSD GNOME team presents a Glib and Gtk+ 3 update.kwm2013-07-311-0/+1 * Remove libbonobomm and libbonobouimm:bapt2013-07-311-1/+0 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-271-4/+0 * MyGUI is a library for creating Graphical User Interfaces (GUIs)amdmi32013-07-271-0/+1 * Add new port: x11-toolkits/qtadamarino2013-07-211-0/+1 * Remove x11-toolkits/linux-f10-qt33 now that we have linux-f10-qt45rene2013-07-131-1/+0 * Add QT4 (Linux Fedora 10).bsam2013-07-131-0/+1 * Add x11-toolkits/py-kivy 1.7.1.dbn2013-07-011-0/+1 * Hierarchic data visualization control intended for use with structures wheresbz2013-06-131-0/+1 * Ruby/GtkSourceView3 is a Ruby binding of gtksourceview-3.x.swills2013-06-101-0/+1 * Ruby/GtkSourceView2 is a Ruby binding of gtksourceview-2.x.swills2013-06-101-0/+1 * Ruby/VTE is a Ruby binding of VTE.swills2013-06-101-0/+1 * Ruby/Poppler is a Ruby binding for Poppler.swills2013-06-101-0/+1 * Ruby/GTK3 is a Ruby binding of GTK+-3.x.swills2013-06-101-0/+1 * Ruby/GDK3 is a Ruby binding of GDK-3.x.swills2013-06-101-0/+1 * Ruby/GTK2 is a Ruby binding for GTK+2.swills2013-06-101-0/+1 * Ruby/Pango is a Ruby binding for Pango.swills2013-06-101-0/+1 * retire ruby-wxdinoex2013-06-071-1/+0 * - Update The Glorious Glasgow Haskell Compiler to version 7.6.3pgj2013-06-051-0/+2 * - Finish removal of support for Linux 2.4 in bsd.linux-apps.mk andrene2013-05-301-5/+0 * Add Gstreamer 1.0.7. This is the new stable version of thekwm2013-04-281-0/+1 * - Remove lang/tcl83 and x11-toolkits/tk83 (expired)gahr2013-04-231-1/+0 * Add gtksourceview 3 ports.kwm2013-03-191-0/+3 * Add libunique3, this is the gtk+3 version of x11-toolkits/unique.kwm2013-03-191-0/+1 * 2012-10-20 x11-toolkits/gtkglarea: No more public distfilesbapt2013-02-141-1/+0 * - Update lang/tcl86 and x11-toolkits/tk86 to 8.6.0gahr2013-02-061-3/+0 * 2012-11-26 x11-toolkits/fltk2: No more public distfiles for version 2bapt2013-02-051-1/+0 * 2012-11-28 x11-toolkits/fltk11: new code should use /x11-toolkits/fltkbapt2013-01-271-1/+0 * - Disconnect fltk-threads from the buildgahr2012-12-171-1/+0 * - Retire Tcl/Tk 8.2 now that the last consumer (deskutils/abacus) has gonegahr2012-12-041-1/+0 * 2012-11-28 chinese/pyDict: Depends on the expired gtkglarea through py-gtk [1]bapt2012-11-291-1/+0 * r307088 broke too much. Rename motif back to open-motif, keeping the 2.3.3 tocy2012-11-071-1/+1 * Update motif from 2.3.3 to 2.3.4.cy2012-11-071-1/+1 * disconnect py-wxPython24 which is already gonebapt2012-10-301-1/+0 * 2012-10-20 x11-toolkits/ocaml-lablgtk: Abandoned upstream, consider using x11...bapt2012-10-281-1/+0 * 2012-10-20 x11-toolkits/paragui: No more upstream, no ports depending on itbapt2012-10-261-1/+0 * Not supported upstream anymore, consider using more recent versionsbapt2012-10-261-3/+0 * 2012-10-20 x11-toolkits/py-SciParam: Depends on the deprecated wx 2.4bapt2012-10-261-7/+0 * Gtk# Beans aims to fill the gap between the current Gtk# packages state and allromain2012-10-161-0/+1 * Developement ceased, and nothing in the ports tree uses it anymorebapt2012-10-15