aboutsummaryrefslogtreecommitdiffstats
path: root/devel/leoarg
diff options
context:
space:
mode:
Diffstat (limited to 'devel/leoarg')
-rw-r--r--devel/leoarg/Makefile11
-rw-r--r--devel/leoarg/pkg-descr2
2 files changed, 9 insertions, 4 deletions
diff --git a/devel/leoarg/Makefile b/devel/leoarg/Makefile
index c5ce443fb4a9..2e9a550c1eb6 100644
--- a/devel/leoarg/Makefile
+++ b/devel/leoarg/Makefile
@@ -20,8 +20,13 @@ USE_INC_LIBTOOL_VER= 13
LIBTOOLFLAGS= --disable-ltlibs --disable-static
INSTALLS_SHLIB= yes
-PLIST_FILES= include/LeoArg.hh lib/libLeoArg.so lib/libLeoArg.so.2
+PLIST_FILES= include/LeoArg.hh lib/libLeoArg.so lib/libLeoArg.so.2 \
+ ${EXAMPLES:S|^|%%EXAMPLESDIR%%/|}
+.if !defined(NOPORTDOCS)
+EXAMPLES= Makefile demo.sh leoargmain.cpp
+PLIST_DIRS= %%EXAMPLESDIR%%
PORTDOCS= *
+.endif
MAN3= LeoArg.3 LeoArg__InvalidOption.3 LeoArg__InvalidSetting.3 \
LeoArg__Option.3 LeoArg__Setting.3 LeoArg_cpp.3 LeoArg_hh.3 \
@@ -38,8 +43,8 @@ post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/html/*.* ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
-.for file in Makefile demo.sh leoargmain.cpp
- ${INSTALL_DATA} ${WRKSRC}/example/${file} ${EXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/example/${f} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/devel/leoarg/pkg-descr b/devel/leoarg/pkg-descr
index 4c97a3b4f475..bdd604f860d6 100644
--- a/devel/leoarg/pkg-descr
+++ b/devel/leoarg/pkg-descr
@@ -1,4 +1,4 @@
With this class you can parse easily commandline options. The class
only uses standard libraries.
-WWW: http://kingleo.home.pages.at/index.php?language=EN&show=/development/cpp/#leoarg
+WWW: http://kingleo.pages.at/index_cpp.xml.php#leoarg