aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libassa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libassa/Makefile')
-rw-r--r--devel/libassa/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/devel/libassa/Makefile b/devel/libassa/Makefile
index ef38c6b44632..e7ae0e456f07 100644
--- a/devel/libassa/Makefile
+++ b/devel/libassa/Makefile
@@ -7,19 +7,24 @@
#
PORTNAME= libassa
-PORTVERSION= 3.4.2
+PORTVERSION= 3.4.2.2
PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.([[:digit:]])$/-\1/}
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= An C++ networking library and application framework
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
-PLIST_SUB= ASSA_VERSION=${PORTVERSION:R}
+PLIST_SUB= ASSA_VERSION=${PORTVERSION:R:R}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/(\.[[:digit:]])$//}
+
+MAN1= assa-genesis.1
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s: doc : :g' ${WRKSRC}/Makefile.in
@@ -30,4 +35,7 @@ post-patch:
BROKEN= compilation fails and passing -fhuge-objects does not help
.endif
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/debian/assa-genesis.1 ${PREFIX}/man/man1
+
.include <bsd.port.post.mk>