aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libcwd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libcwd/Makefile')
-rw-r--r--devel/libcwd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/libcwd/Makefile b/devel/libcwd/Makefile
index cdc6aba64dc0..43c7c8a11353 100644
--- a/devel/libcwd/Makefile
+++ b/devel/libcwd/Makefile
@@ -19,7 +19,12 @@ CONFIGURE_ARGS= --disable-threading
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e 's,test x"\$$libcwd_config_alloc" = x"yes",false,g' \
@@ -37,4 +42,4 @@ post-patch:
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>