aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libepoll-shim
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libepoll-shim')
-rw-r--r--devel/libepoll-shim/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/libepoll-shim/Makefile b/devel/libepoll-shim/Makefile
index 4cda215546e3..13ed55eaaef0 100644
--- a/devel/libepoll-shim/Makefile
+++ b/devel/libepoll-shim/Makefile
@@ -10,8 +10,6 @@ COMMENT= epoll shim implemented using kevent
LICENSE= MIT
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -Wno-missing-variable-declarations
-
USE_GITHUB= yes
GH_ACCOUNT= FreeBSDDesktop
GH_PROJECT= epoll-shim
@@ -19,14 +17,18 @@ GH_TAGNAME= c04b26b
USE_LDCONFIG= yes
-USES= uidfix
-MAKE_ARGS= LIBDIR=${PREFIX}/lib INCLUDEDIR=${PREFIX}/include
+USES= compiler uidfix
+MAKE_ARGS= LIBDIR=${PREFIX}/lib INCSDIR=${PREFIX}/include/libepoll-shim/sys
+
+.include <bsd.port.pre.mk>
post-patch:
- # -Weverything is not recognized by GCC
- @${REINPLACE_CMD} -e 's|Weverything|Wall|' ${WRKSRC}/Makefile
+.if "${CHOSEN_COMPILER_TYPE}" == "gcc"
+ @${REINPLACE_CMD} -e 's|Wno-missing-variable-declarations|Wno-missing-declarations|' \
+ -e 's|-Wno-thread-safety-analysis||' -e 's|Weverything|Wall|' ${WRKSRC}/Makefile
+.endif
pre-install:
@${MKDIR} ${STAGEDIR}/${PREFIX}/include/libepoll-shim/sys
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>