aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libisofs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libisofs/Makefile')
-rw-r--r--devel/libisofs/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/libisofs/Makefile b/devel/libisofs/Makefile
new file mode 100644
index 000000000000..e8849b6de13b
--- /dev/null
+++ b/devel/libisofs/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libisofs
+# Date created: 2008 November 06
+# Whom: J.R. Oldroyd <fbsd@opal.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libisofs
+PORTVERSION= 0.6.10
+CATEGORIES= devel
+MASTER_SITES= http://files.libburnia-project.org/releases/
+
+MAINTAINER= fbsd@opal.com
+COMMENT= Libburnia ISO9660 filesystem creation library
+
+LIB_DEPENDS= burn.23:${PORTSDIR}/devel/libburn
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= CFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -liconv"
+
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ ${MV} ${PREFIX}/lib/pkgconfig/${PORTNAME}-1.pc ${PREFIX}/libdata/pkgconfig/${PORTNAME}-1.pc
+ ${RMDIR} ${PREFIX}/lib/pkgconfig
+
+.include <bsd.port.post.mk>