aboutsummaryrefslogtreecommitdiffstats
path: root/devel/librelp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/librelp/Makefile')
-rw-r--r--devel/librelp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/librelp/Makefile b/devel/librelp/Makefile
new file mode 100644
index 000000000000..2cadb76f2420
--- /dev/null
+++ b/devel/librelp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: librelp
+# Date created: 1 April 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librelp
+PORTVERSION= 0.1.1
+CATEGORIES= devel
+MASTER_SITES= CENKES http://download.rsyslog.com/librelp/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Reliable event logging protocol library
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+PLIST_FILES= include/${PORTNAME}.h lib/${PORTNAME}.so lib/${PORTNAME}.so.0 \
+ lib/${PORTNAME}.la libdata/pkgconfig/relp.pc
+PORT_VERBS= relp
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/s|=.*| \
+ = ${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+ @${ECHO_CMD} "#include <sys/types.h>" >> ${WRKSRC}/src/relp.h
+
+.include <bsd.port.mk>