aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libsigscan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libsigscan/Makefile')
-rw-r--r--devel/libsigscan/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/devel/libsigscan/Makefile b/devel/libsigscan/Makefile
index ceb5060332f8..1be4da6d1a9a 100644
--- a/devel/libsigscan/Makefile
+++ b/devel/libsigscan/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libsigscan
# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
-DISTVERSION= experimental-20160312
+DISTVERSION= experimental-20170124
CATEGORIES= devel
MASTER_SITES= https://github.com/libyal/libsigscan/releases/download/${PORTVERSION:E}/ \
LOCAL/antoine
@@ -15,17 +15,21 @@ LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE}
-USES= gettext libtool pathfix python
+CONFIGURE_ARGS= --enable-python
+USES= libtool pathfix python
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
-PORTDOCS= AUTHORS ChangeLog
+OPTIONS_DEFINE= DOCS NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
-OPTIONS_DEFINE= DOCS
+PORTDOCS= AUTHORS ChangeLog
-post-install-DOCS-on:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}