aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux-js/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/linux-js/Makefile')
-rw-r--r--devel/linux-js/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index a2bdbe97a335..8d150dc2580c 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -33,10 +33,6 @@ MAKE_ENV= WITHOUT_DEBUG=yes
IGNORE= requires FreeBSD 5.3 or superior
.endif
-.if ${OSVERSION} >= 700000
-IGNORE= module cannot be loaded on FreeBSD 7.x
-.endif
-
.if !exists(/usr/src/sys/Makefile)
IGNORE= requires kernel source files
.endif
@@ -55,6 +51,10 @@ MAKE_ENV+= WITHOUT_UHID=yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/linux_js.4
+.if ${OSVERSION} >= 700000
+ @${REINPLACE_CMD} -e 's|FILEDESC_UNLOCK|FILEDESC_SUNLOCK|' ${WRKSRC}/linux_js.c
+ @${REINPLACE_CMD} -e 's|FILEDESC_LOCK|FILEDESC_SLOCK|' ${WRKSRC}/linux_js.c
+.endif
post-install:
${MKDIR} ${PREFIX}/include/linux