aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mpatrol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mpatrol/Makefile')
-rw-r--r--devel/mpatrol/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index 203f54603bf4..57a5b80fb9bd 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
WRKSRC= ${WRKDIR}/${PORTNAME}/build/unix
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
INSTALLS_SHLIB= yes
USE_GMAKE= yes
@@ -42,6 +42,12 @@ DOCSIMG= cc1.eps cc1.jpg cc1.pdf \
test.eps test.jpg test.pdf \
trace.eps trace.jpg trace.pdf
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -DENVIRON=\"ENVIRON_64\" -DMP_INIT_SUPPORT=0
+.endif
+
do-install:
.for file in hexwords mpedit mpsym mupdate
${INSTALL_SCRIPT} ${WRKSRC}/../../bin/${file} ${PREFIX}/bin
@@ -77,4 +83,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>