aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oaf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/oaf/Makefile')
-rw-r--r--devel/oaf/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 3905b08914b8..7f6472c36f6b 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -19,23 +19,20 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gtk12 orbit libxml
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_GNOMELIBS= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
- --disable-more-warnings --disable-gtk-doc
+ --disable-more-warnings
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= oafd.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>