aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ocaml-camomile-examples/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-camomile-examples/Makefile')
-rw-r--r--devel/ocaml-camomile-examples/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/ocaml-camomile-examples/Makefile b/devel/ocaml-camomile-examples/Makefile
new file mode 100644
index 000000000000..beb3e92152eb
--- /dev/null
+++ b/devel/ocaml-camomile-examples/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ocaml-camomile-examples
+# Date created: 2006-07-27
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= camomile
+PORTVERSION= 0.4.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ocaml-
+PKGNAMESUFFIX= -examples
+DISTNAME= examples-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Example programs for Camomile library
+
+WRKSRC= ${WRKDIR}/examples
+NO_BUILD= yes
+USE_BZIP2= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${TAR} -cf- -C ${WRKSRC} . | \
+ ${TAR} -xf- -C ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${FIND} ${EXAMPLESDIR} -exec ${CHOWN} ${SHAREOWN} {} \;
+
+.include <bsd.port.mk>