aboutsummaryrefslogtreecommitdiffstats
path: root/devel/oniguruma4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/oniguruma4/Makefile')
-rw-r--r--devel/oniguruma4/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
index dce59d5d9da5..9d565cf7934c 100644
--- a/devel/oniguruma4/Makefile
+++ b/devel/oniguruma4/Makefile
@@ -32,13 +32,15 @@ post-configure:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/sample/*.c ${WRKSRC}/sample/Makefile* \
- ${EXAMPLESDIR}/
${MKDIR} ${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.c ${WRKSRC}/sample/Makefile* \
+ ${EXAMPLESDIR}/
+.endif
.include <bsd.port.mk>