aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Class-Adapter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Class-Adapter/Makefile')
-rw-r--r--devel/p5-Class-Adapter/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/devel/p5-Class-Adapter/Makefile b/devel/p5-Class-Adapter/Makefile
index 480e696db544..1f7bda7b6ffe 100644
--- a/devel/p5-Class-Adapter/Makefile
+++ b/devel/p5-Class-Adapter/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= Class-Adapter
-PORTVERSION= 1.03
+PORTVERSION= 1.04
CATEGORIES= devel perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Class
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= Perl implementation of the "Adapter" Design Pattern
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes