aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Devel-Profile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Devel-Profile')
-rw-r--r--devel/p5-Devel-Profile/Makefile26
-rw-r--r--devel/p5-Devel-Profile/distinfo1
-rw-r--r--devel/p5-Devel-Profile/pkg-descr6
-rw-r--r--devel/p5-Devel-Profile/pkg-plist3
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Devel-Profile/Makefile b/devel/p5-Devel-Profile/Makefile
new file mode 100644
index 000000000000..1597404826a3
--- /dev/null
+++ b/devel/p5-Devel-Profile/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Devel-Profile
+# Date created: 16 march 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-Profile
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Tell me why my perl program runs so slowly
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Devel::Profile.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Devel-Profile/distinfo b/devel/p5-Devel-Profile/distinfo
new file mode 100644
index 000000000000..645dc549e428
--- /dev/null
+++ b/devel/p5-Devel-Profile/distinfo
@@ -0,0 +1 @@
+MD5 (Devel-Profile-1.01.tar.gz) = 08561aceb83895e0862e663205dcc19c
diff --git a/devel/p5-Devel-Profile/pkg-descr b/devel/p5-Devel-Profile/pkg-descr
new file mode 100644
index 000000000000..9de0fcfa480c
--- /dev/null
+++ b/devel/p5-Devel-Profile/pkg-descr
@@ -0,0 +1,6 @@
+The Devel::Profile package is a Perl code profiler. This will collect
+information on the execution time of a Perl script and of the subs in that
+script. This information can be used to determine which subroutines are using
+the most time and which subroutines are being called most often.
+
+WWW: http://search.cpan.org/author/JAW/Devel-Profile
diff --git a/devel/p5-Devel-Profile/pkg-plist b/devel/p5-Devel-Profile/pkg-plist
new file mode 100644
index 000000000000..6a621405e65f
--- /dev/null
+++ b/devel/p5-Devel-Profile/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Devel/Profile.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Devel/Profile/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Devel/Profile