aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Exception-Class/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Exception-Class/Makefile')
-rw-r--r--devel/p5-Exception-Class/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/p5-Exception-Class/Makefile b/devel/p5-Exception-Class/Makefile
index 752657c8390f..4598ab767e27 100644
--- a/devel/p5-Exception-Class/Makefile
+++ b/devel/p5-Exception-Class/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Exception-Class
-PORTVERSION= 1.26
+PORTVERSION= 1.29
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,18 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A module that allows you to declare real exception classes in Perl
-BUILD_DEPENDS= ${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
- ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Class-Data-Inheritable>=0.02:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Devel-StackTrace>=1.20:${PORTSDIR}/devel/p5-Devel-StackTrace
+BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.1+
-MAN3= Exception::Class.3
+MAN3= Exception::Class.3 Exception::Class::Base.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500702
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>