aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-ExtUtils-ParseXS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-ExtUtils-ParseXS/Makefile')
-rw-r--r--devel/p5-ExtUtils-ParseXS/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/p5-ExtUtils-ParseXS/Makefile b/devel/p5-ExtUtils-ParseXS/Makefile
index b310990ec024..893a9470e0c7 100644
--- a/devel/p5-ExtUtils-ParseXS/Makefile
+++ b/devel/p5-ExtUtils-ParseXS/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= ExtUtils-ParseXS
-PORTVERSION= 2.22.06
+PORTVERSION= 3.03
CATEGORIES= devel perl5
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SMUELLER
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= demon@FreeBSD.org
COMMENT= Converts Perl XS code into C code
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.1+
-MAN3= ExtUtils::ParseXS.3
+MAN3= ExtUtils::ParseXS.3 \
+ ExtUtils::ParseXS::Constants.3 \
+ ExtUtils::ParseXS::Utilities.3 \
+ ExtUtils::Typemaps.3 \
+ ExtUtils::Typemaps::InputMap.3 \
+ ExtUtils::Typemaps::OutputMap.3 \
+ ExtUtils::Typemaps::Type.3
.include <bsd.port.pre.mk>
@@ -25,4 +31,7 @@ MAN3= ExtUtils::ParseXS.3
BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
+
.include <bsd.port.post.mk>