aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Getopt-Popt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Getopt-Popt/Makefile')
-rw-r--r--devel/p5-Getopt-Popt/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Getopt-Popt/Makefile b/devel/p5-Getopt-Popt/Makefile
new file mode 100644
index 000000000000..aefc0011126f
--- /dev/null
+++ b/devel/p5-Getopt-Popt/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Getopt-Popt
+# Date created: 04 November 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Popt
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Getopt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Perl interface to the popt(3) library
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC='-I${LOCALBASE}/include' LIBS'-L${LOCALBASE}/lib'
+
+MAN3= Getopt::Popt.3
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/ex
+ @${MV} ${WRKSRC}/example.pl ${WRKSRC}/ex
+
+.include <bsd.port.mk>