aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Glib-Object-Introspection/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Glib-Object-Introspection/Makefile')
-rw-r--r--devel/p5-Glib-Object-Introspection/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Glib-Object-Introspection/Makefile b/devel/p5-Glib-Object-Introspection/Makefile
new file mode 100644
index 000000000000..6d06ecfdcd3a
--- /dev/null
+++ b/devel/p5-Glib-Object-Introspection/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Glib-Object-Introspection
+# Date created: 2011-10-15
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Glib-Object-Introspection
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Dynamically create Perl language bindings
+
+BUILD_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
+ p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+RUN_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
+ p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+
+PERL_CONFIGURE= yes
+
+MAN3= Glib::Object::Introspection.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc -shared -g|& -fPIC|' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>