aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Inline-CPP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Inline-CPP/Makefile')
-rw-r--r--devel/p5-Inline-CPP/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
index 5cb840cf3d09..ea11fc84f920 100644
--- a/devel/p5-Inline-CPP/Makefile
+++ b/devel/p5-Inline-CPP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Inline-CPP
-PORTVERSION= 0.38
+PORTVERSION= 0.39
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,13 +14,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Write Perl subroutines and classes in C++
+LICENSE= ART10
+
BUILD_DEPENDS= p5-Inline>=0.50:${PORTSDIR}/devel/p5-Inline \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Kwalitee>=0:${PORTSDIR}/devel/p5-Test-Kwalitee
PERL_CONFIGURE= yes
-MAN3= Inline::CPP.3
+MAN3= Inline::CPP.3 \
+ Inline::CPP::Config.3 \
+ Inline::CPP::grammar.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>