aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Module-Pluggable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Module-Pluggable/Makefile')
-rw-r--r--devel/p5-Module-Pluggable/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-Module-Pluggable/Makefile b/devel/p5-Module-Pluggable/Makefile
new file mode 100644
index 000000000000..a9199dc74f0a
--- /dev/null
+++ b/devel/p5-Module-Pluggable/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Module-Pluggable
+# Date created: 2004-07-26
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Pluggable
+PORTVERSION= 1.9
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Automatically give your module the ability to have plugins
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Module::Pluggable.3
+
+.include <bsd.port.mk>