aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Net-LibIDN/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Net-LibIDN/Makefile')
-rw-r--r--devel/p5-Net-LibIDN/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Net-LibIDN/Makefile b/devel/p5-Net-LibIDN/Makefile
new file mode 100644
index 000000000000..a0c46d0cd753
--- /dev/null
+++ b/devel/p5-Net-LibIDN/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-LibIDN
+# Date created: 06 March 2004
+# Whom: Dominik Brettnacher <domi@saargate.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-LibIDN
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/T/TH/THOR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= domi@saargate.de
+COMMENT= This module provides access to the libidn library
+
+LIB_DEPENDS= idn.13:${PORTSDIR}/devel/libidn
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-libidn=${PREFIX}/lib --with-libidn-inc=${PREFIX}/include
+
+MAN3= Net::LibIDN.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>