aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-POEx-Role-Streaming/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-POEx-Role-Streaming/Makefile')
-rw-r--r--devel/p5-POEx-Role-Streaming/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-POEx-Role-Streaming/Makefile b/devel/p5-POEx-Role-Streaming/Makefile
new file mode 100644
index 000000000000..0e200a796065
--- /dev/null
+++ b/devel/p5-POEx-Role-Streaming/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: POEx::Role::Streaming
+# Date created: 10 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Role-Streaming
+PORTVERSION= 1.102610
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/N/NP/NPEREZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for streaming from one filehandle to another
+
+RUN_DEPENDS= \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POEx-Role-SessionInstantiation>=0:${PORTSDIR}/devel/p5-POEx-Role-SessionInstantiation \
+ p5-POEx-Types>0:${PORTSDIR}/devel/p5-POEx-Types \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Role::Streaming.3
+
+.include <bsd.port.mk>