aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-RRDTool-OO/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-RRDTool-OO/Makefile')
-rw-r--r--devel/p5-RRDTool-OO/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-RRDTool-OO/Makefile b/devel/p5-RRDTool-OO/Makefile
new file mode 100644
index 000000000000..0395d0ef697c
--- /dev/null
+++ b/devel/p5-RRDTool-OO/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: RRDTool-OO
+# Date created: 13 Feb 2006
+# Whom: Stefan Pauly <stefan@fh-mainz.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RRDTool-OO
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MS/MSCHILLI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= stefan@fh-mainz.de
+COMMENT= RRDTool::OO - Object-oriented interface to RRDTool
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= RRDTool::OO.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>