aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-Inline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Inline/Makefile')
-rw-r--r--devel/p5-Test-Inline/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
index af2816c9d678..1845e1ce52d1 100644
--- a/devel/p5-Test-Inline/Makefile
+++ b/devel/p5-Test-Inline/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +24,15 @@ MAN1= pod2test.1
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
+PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
+
+.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+
+.include <bsd.port.post.mk>