aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-RandomResults/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-RandomResults/Makefile')
-rw-r--r--devel/p5-Test-RandomResults/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Test-RandomResults/Makefile b/devel/p5-Test-RandomResults/Makefile
new file mode 100644
index 000000000000..d20a9d130fb1
--- /dev/null
+++ b/devel/p5-Test-RandomResults/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Test-RandomResults
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-RandomResults
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Test non-deterministic functions
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Test::RandomResults.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>