aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-SubCalls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-SubCalls/Makefile')
-rw-r--r--devel/p5-Test-SubCalls/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-Test-SubCalls/Makefile b/devel/p5-Test-SubCalls/Makefile
new file mode 100644
index 000000000000..775ec15f1675
--- /dev/null
+++ b/devel/p5-Test-SubCalls/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-Test-SubCalls
+# Date created: 08 October 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-SubCalls
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Track the number of times subs are called
+
+BUILD_DEPENDS= ${SITE_PERL}/Hook/LexWrap.pm:${PORTSDIR}/devel/p5-Hook-LexWrap \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::SubCalls.3
+
+post-patch:
+ @${RM} ${WRKSRC}/inc/Module/Install/AutoInstall.pm
+ @${PERL} -pi -e '$$_="" if m/AutoInstall/' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500601 # inherited from devel/p5-Hook-LexWrap
+IGNORE= requires perl 5.6.1 or newer. Install lang/perl5 or lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>