aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-relative/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-relative/Makefile')
-rw-r--r--devel/p5-relative/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-relative/Makefile b/devel/p5-relative/Makefile
new file mode 100644
index 000000000000..3e344d25f2d7
--- /dev/null
+++ b/devel/p5-relative/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-relative
+# Date created: Tue Dec 9 11:32:16 EST 2008
+# Whom: skreuzer@exit2shell.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= relative
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SA/SAPER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@exit2shell.com
+COMMENT= Load modules with relative names
+
+RUN_DEPENDS= p5-UNIVERSAL-require>=0.11:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+BUILD_DEPEND= ${RUN_DEPENDS} \
+ p5-Test-Simple>=0.74:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= relative.3
+
+.include <bsd.port.mk>