aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pccts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pccts/Makefile')
-rw-r--r--devel/pccts/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/devel/pccts/Makefile b/devel/pccts/Makefile
index f00c778a4662..5b321b66574b 100644
--- a/devel/pccts/Makefile
+++ b/devel/pccts/Makefile
@@ -1,25 +1,30 @@
# New ports collection makefile for: pccts
-# Version required: 1.33
+# Version required: 1.33.19
# Date created: 22 June 1997
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.2 1998/11/21 20:04:34 steve Exp $
+# $Id: Makefile,v 1.3 1999/04/20 02:05:24 mharo Exp $
#
-DISTNAME= pccts
-PKGNAME= pccts-1.33
+DISTNAME= pccts133mr
+PKGNAME= pccts-1.33.19
CATEGORIES= devel
-MASTER_SITES= http://www.antlr.org/1.33/
+MASTER_SITES= http://www.polhode.com/
MAINTAINER= andy@icc.surw.chel.su
-MAKEFILE= makefile
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/pccts
ALL_TARGET=
+MAKEFILE= makefile
+
MAN1= antlr.1 dlg.1 pccts.1
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/antlr ${PREFIX}/bin/antlr
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dlg ${PREFIX}/bin/dlg
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/antlr ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dlg ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/genmk ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/sor ${PREFIX}/bin
.for file in pccts antlr/antlr dlg/dlg
@ ${INSTALL_MAN} ${WRKSRC}/${file}.1 ${PREFIX}/man/man1
.endfor
@@ -30,7 +35,7 @@ do-install:
.for file in AParser ASTBase ATokPtr ATokenBuffer DLexer DLexerBase PCCTSAST SList
@ ${INSTALL_DATA} ${WRKSRC}/h/${file}.cpp ${PREFIX}/include/pccts/${file}.cpp
.endfor
-.for file in AParser ASTBase ATokPtr AToken ATokenBuffer ATokenStream DLexerBase PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto dlgdef err int
+.for file in AParser ASTBase ATokPtr AToken ATokenBuffer ATokenStream DLexerBase PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto dlgdef err int pcctscfg pccts_assert pccts_setjmp pccts_stdarg pccts_stdio pccts_stdlib pccts_string pccts_iostream pccts_istream
@ ${INSTALL_DATA} ${WRKSRC}/h/${file}.h ${PREFIX}/include/pccts/${file}.h
.endfor
@ ${MKDIR} ${PREFIX}/share/examples/pccts
@@ -40,9 +45,11 @@ do-install:
.for file in makefile 1/makefile 1/test.g 2/MyLexer.cpp 2/MyLexer.h 2/makefile 2/test.g 3/MyLexer.cpp 3/MyLexer.h 3/makefile 3/mytokens.h 3/test.g 4/makefile 4/mytokens.h 4/test.g 5/input.h 5/makefile 5/test.g 6/file1 6/file2 6/main.cpp 6/makefile 6/makefile2 6/test.g 6/test2.g 7/makefile 7/test.g 8/main.cpp 8/makefile 8/test.g 9/makefile 9/test.g 10/makefile 10/test.g 11/input.h 11/makefile 11/test.g 12/makefile 12/test.g 13/makefile 13/test.g
@ ${INSTALL_DATA} ${WRKSRC}/testcpp/${file} ${PREFIX}/share/examples/pccts/${file}
.endfor
+
+post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/pccts
-.for file in BOOK README RIGHTS SERVICES history.ps history.txt
+.for file in CHANGES_FROM_131.txt CHANGES_FROM_133.txt CHANGES_FROM_133_BEFORE_MR13.txt KNOWN_PROBLEMS.txt README RIGHTS SERVICES history.ps history.txt old_README
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/pccts/${file}
.endfor
.endif