aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-PEAR/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-PEAR/Makefile')
-rw-r--r--devel/pear-PEAR/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
index 9b64f62c16ca..923e82aed9f5 100644
--- a/devel/pear-PEAR/Makefile
+++ b/devel/pear-PEAR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= PEAR
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel www
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -26,7 +26,10 @@ NO_BUILD= yes
.if exists(${LOCALBASE}/bin/php-config)
PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE!= ${LOCALBASE}
.endif
+PEAR= ${LOCALBASE}/bin/pear
LPHP_LIB= lib/php
PEARDIR= ${PHP_BASE}/${LPHP_LIB}
PLIST_SUB= PEARDIR=${LPHP_LIB}
@@ -42,4 +45,8 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${FILE}
.endfor
+post-install:
+# Register an upgraded package
+ @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
+
.include <bsd.port.post.mk>