aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-XML_Serializer
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-XML_Serializer')
-rw-r--r--devel/pear-XML_Serializer/Makefile25
-rw-r--r--devel/pear-XML_Serializer/distinfo4
-rw-r--r--devel/pear-XML_Serializer/pkg-descr30
3 files changed, 37 insertions, 22 deletions
diff --git a/devel/pear-XML_Serializer/Makefile b/devel/pear-XML_Serializer/Makefile
index a963b8ef0f54..66e3b92400ac 100644
--- a/devel/pear-XML_Serializer/Makefile
+++ b/devel/pear-XML_Serializer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML_Serializer
-PORTVERSION= 0.15.0
+PORTVERSION= 0.16.0
CATEGORIES= devel www pear
MAINTAINER= antonio@php.net
@@ -16,19 +16,32 @@ BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_REINPLACE= yes
+
CATEGORY= XML
FILES= Serializer.php Unserializer.php
EXAMPLES= example.xml serializeAndEncode.php serializeAndReturn.php \
serializeArrayWithObjects.php serializeEmptyArray.php \
- serializeIndexedArray.php serializeObject.php serializeRDF.php \
- serializeWithAttributes.php serializeWithAttributes2.php \
+ serializeIndexedArray.php serializeNullProperties.php \
+ serializeObject.php serializeRDF.php serializeWithAttributes.php \
+ serializeWithAttributes2.php serializeWithComment.php \
serializeWithDtd.php serializeWithIndentedAttributes.php \
- serializeWithNamespace.php serializeWithTagMap.php unserializeAnyXML.php \
- unserializeClassNames.php unserializeEncoded.php unserializeEnum.php \
- unserializeObject.php unserializeRDF.php unserializeWithAttributes.php
+ serializeWithNamespace.php serializeWithTagMap.php \
+ unserializeAnyXML.php unserializeClassNames.php \
+ unserializeEncoded.php unserializeEnum.php unserializeObject.php \
+ unserializeRDF.php unserializeWithAttributes.php \
+ unserializeWithTagMap.php
DOCS= todo.txt
_DOCSDIR= doc
+post-extract:
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" ${WRKSRC}/${file}
+.endfor
+.for file in ${EXAMPLES}
+ @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" ${WRKSRC}/examples/${file}
+.endfor
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/devel/pear-XML_Serializer/distinfo b/devel/pear-XML_Serializer/distinfo
index e9866ccdae3b..810896d26cf9 100644
--- a/devel/pear-XML_Serializer/distinfo
+++ b/devel/pear-XML_Serializer/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/XML_Serializer-0.15.0.tgz) = 81b7a5b6e1ac6bde8bbf396187483e81
-SIZE (PEAR/XML_Serializer-0.15.0.tgz) = 17218
+MD5 (PEAR/XML_Serializer-0.16.0.tgz) = 67c45ebf1dab5ddc37b294436df734bb
+SIZE (PEAR/XML_Serializer-0.16.0.tgz) = 19621
diff --git a/devel/pear-XML_Serializer/pkg-descr b/devel/pear-XML_Serializer/pkg-descr
index c15d05dadeb6..29f691276f1a 100644
--- a/devel/pear-XML_Serializer/pkg-descr
+++ b/devel/pear-XML_Serializer/pkg-descr
@@ -1,20 +1,22 @@
-XML_Serializer serializes complex data structures like arrays or object
+PEAR::XML_Serializer serializes complex data structures like arrays or object
as XML documents.
-This class helps you generating any XML document you require without the
-need for DOM.
+
+This class helps you generating any XML document you require without the need
+for DOM.
+
Furthermore this package can be used as a replacement to serialize() and
-unserialize() as it comes with a matching XML_Unserializer that is able to
-create PHP data strcutures (like arrays and objects) from XML documents,
-if type hints are available.
+unserialize() as it comes with a matching XML_Unserializer that is able to
+create PHP data structures (like arrays and objects) from XML documents, if
+type hints are available.
+
+If you use the XML_Unserializer on standard XML files, it will try to guess
+how it has to be unserialized. In most cases it does exactly what you expect
+it to do.
-If you use the XML_Unserialzer on standard XML files, it will try to guess
-how it has to be unserialized. In most cases it does exactly what you
-expect it to do.
-Try reading a RSS file with XML_Unserializer and you have the whole RSS
-file in a structured array or even a collection of objects, similar to
-XML_RSS.
+Try reading a RSS file with XML_Unserializer and you have the whole RSS file
+in a structured array or even a collection of objects, similar to XML_RSS.
-Since version 0.8 the package is able to treat XML documents like the
-simplexml extension of PHP 5.
+Since version 0.8.0 the package is able to treat XML documents similar to
+the simplexml extension of PHP 5.
WWW: http://pear.php.net/package/XML_Serializer/