aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-apd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-apd/Makefile')
-rw-r--r--devel/pear-apd/Makefile38
1 files changed, 16 insertions, 22 deletions
diff --git a/devel/pear-apd/Makefile b/devel/pear-apd/Makefile
index be00df70cf72..833b2c7d5c54 100644
--- a/devel/pear-apd/Makefile
+++ b/devel/pear-apd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= apd
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= devel pear
MAINTAINER= ports@FreeBSD.org
@@ -15,49 +15,43 @@ COMMENT= A full-featured engine-level PHP profiler/debugger
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not compile
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
USE_PHP= yes
USE_PHPIZE= yes
+DEFAULT_PHP_VER=5
+BROKEN_WITH_PHP=4
+
+IGNORE= "cannot build package if pear-* have been built with PHP4"
CONFIGURE_ARGS= --enable-apd
+DUMP_DIR?= /var/tmp/apd
+
+PORTDOCS= README
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
-.if exists(${LOCALBASE}/bin/php-config)
-EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
- "s:${PHP_BASE}/::"
-.endif
-PHP_DIR?= ${LOCALBASE}/etc
-DUMP_DIR?= /var/tmp/apd
-PHP_INI= ${PHP_DIR}/php.ini
-PLIST_SUB+= EXTDIR=${EXT_DIR}
-DOCS= README
+PLIST_SUB+= EXTDIR=lib/php/${PHP_EXT_DIR}
+
+SUB_FILES= pkg-message
+SUB_LIST= PHP_EXT_DIR=${PHP_EXT_DIR} DUMP_DIR=${DUMP_DIR}
post-extract:
@${CHMOD} -R u+w ${WRKSRC}
post-install-script:
- @${STRIP_CMD} ${PHP_BASE}/${EXT_DIR}/apd.so
+ @${STRIP_CMD} ${PHP_BASE}/lib/php/${PHP_EXT_DIR}/apd.so
@${MKDIR} ${DUMP_DIR}
@${CHMOD} a+w ${DUMP_DIR}
${INSTALL_SCRIPT} ${WRKSRC}/pprofp ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
+.for FILE in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
@${ECHO_MSG}
- @${CAT} ${PKGMESSAGE} | \
- ${SED} -e "s:/usr/local/etc/php.ini:${PHP_INI}:" \
- -e "s:/usr/local:${LOCALBASE}:" \
- -e "s:lib/php/20020429:${EXT_DIR}:" \
- -e "s:/var/tmp/apd:${DUMP_DIR}:"
- @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>