aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pkgconfig
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pkgconfig')
-rw-r--r--devel/pkgconfig/Makefile6
-rw-r--r--devel/pkgconfig/distinfo4
-rw-r--r--devel/pkgconfig/files/patch-parse.c1
-rw-r--r--devel/pkgconfig/pkg-descr19
4 files changed, 14 insertions, 16 deletions
diff --git a/devel/pkgconfig/Makefile b/devel/pkgconfig/Makefile
index 742b418057fe..4a66677fc427 100644
--- a/devel/pkgconfig/Makefile
+++ b/devel/pkgconfig/Makefile
@@ -3,19 +3,21 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/pkgconfig/Makefile,v 1.6 2005/10/14 20:39:57 adamw Exp $
#
PORTNAME= pkgconfig
-PORTVERSION= 0.17.2
+PORTVERSION= 0.19
CATEGORIES= devel
MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
+DISTNAME= pkg-config-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A utility to retrieve information about installed libraries
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget
LIBTOOLFILES= glib-1.2.8/configure
LIBTOOLFLAGS= --disable-ltlibs \
diff --git a/devel/pkgconfig/distinfo b/devel/pkgconfig/distinfo
index 20b35cccca85..220f87d0cfa3 100644
--- a/devel/pkgconfig/distinfo
+++ b/devel/pkgconfig/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/pkgconfig-0.17.2.tar.gz) = a0829ae71b586e027183b2a1cfe0ce88
-SIZE (gnome2/pkgconfig-0.17.2.tar.gz) = 965129
+MD5 (gnome2/pkg-config-0.19.tar.gz) = 25f106d2cc82a0013f5bdc89875d5790
+SIZE (gnome2/pkg-config-0.19.tar.gz) = 968790
diff --git a/devel/pkgconfig/files/patch-parse.c b/devel/pkgconfig/files/patch-parse.c
index b591663c5709..eb828f3e7743 100644
--- a/devel/pkgconfig/files/patch-parse.c
+++ b/devel/pkgconfig/files/patch-parse.c
@@ -1,5 +1,6 @@
$FreeBSD$
+$MCom: ports/devel/pkgconfig/files/patch-parse.c,v 1.4 2005/10/14 20:39:57 adamw Exp $
--- parse.c 2001/08/01 07:24:17 1.1
+++ parse.c 2001/08/01 07:25:02
diff --git a/devel/pkgconfig/pkg-descr b/devel/pkgconfig/pkg-descr
index afd75d04435b..c24838f6230e 100644
--- a/devel/pkgconfig/pkg-descr
+++ b/devel/pkgconfig/pkg-descr
@@ -1,18 +1,13 @@
The pkg-config program is used to retrieve information about installed
libraries in the system. It is typically used to compile and link against one
-or more libraries.
+or more libraries. It's more useful to the compilation process than to
+the end-user.
pkg-config retrieves information about packages from special metadata files.
These files are named after the package, with the extension .pc. By default,
-pkg-config looks in the following directories: ${PREFIX}/libdata/pkgconfig,
-${LOCALBASE}/libdata/pkgconfig and ${X11BASE}/libdata/pkgconfig for these
-files; it will also look in the list of directories specified by the
-PKG_CONFIG_PATH environment variable.
+pkg-config looks for these files in the following directories:
+${PREFIX}/libdata/pkgconfig, ${LOCALBASE}/libdata/pkgconfig and
+${X11BASE}/libdata/pkgconfig; it will also look in the list of directories
+specified by the PKG_CONFIG_PATH environment variable.
-The package name specified on the pkg-config command line is defined to be the
-name of the metadata file, minus the .pc extension. If a library can install
-multiple versions simultaneously, it must give each version its own name (for
-example, GTK 1.2 might have the package name "gtk+" while GTK 2.0 has
-"gtk+-2.0").
-
-WWW: http://www.freedesktop.org/wiki/Software_2fpkgconfig
+WWW: http://pkgconfig.freedesktop.org/wiki/