aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ptlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ptlib/Makefile')
-rw-r--r--devel/ptlib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index a44aa3b92cd1..f9a086e4b98b 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -16,11 +16,12 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
CONFLICTS= pwlib-1.*
-USES= autoreconf:build bison gmake pathfix pkgconfig ssl tar:xz
+USES= autoreconf:build bison compiler:c11 gmake localbase:ldflags \
+ pathfix pkgconfig ssl tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${OPENSSLINC} -I${LOCALBASE}/include
-LDFLAGS+= -L${OPENSSLLIB} -L${LOCALBASE}/lib
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
CONFIGURE_ARGS+=--enable-audio \
--enable-ipv6 \