aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-asn1-modules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-asn1-modules/Makefile')
-rw-r--r--devel/py-asn1-modules/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/devel/py-asn1-modules/Makefile b/devel/py-asn1-modules/Makefile
index d5683f5f8951..27a89b6c2704 100644
--- a/devel/py-asn1-modules/Makefile
+++ b/devel/py-asn1-modules/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: py-asn1-modules
-# Date created: 20 March 2011
-# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
-#
# $FreeBSD$
-#
PORTNAME= asn1-modules
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.5
CATEGORIES= devel python
MASTER_SITES= SF/pyasn1/py${PORTNAME}/${PORTVERSION} \
CHEESESHOP
@@ -20,7 +15,6 @@ LICENSE= BSD
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.4:${PORTSDIR}/devel/py-asn1
-# Python3 ready
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= pyasn1-modules
@@ -33,11 +27,13 @@ TOOLS= cmpdump.py crldump.py crmfdump.py ocspclient.py ocspreqdump.py \
ocsprspdump.py ocspserver.py pkcs10dump.py pkcs1dump.py \
pkcs7dump.py pkcs8dump.py snmpget.py x509dump.py
+.include <bsd.port.options.mk>
+
post-install:
.for t in ${TOOLS}
@${INSTALL_SCRIPT} ${WRKSRC}/tools/${t} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${BASEDOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}