aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-clikit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-clikit/Makefile')
-rw-r--r--devel/py-clikit/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/py-clikit/Makefile b/devel/py-clikit/Makefile
new file mode 100644
index 000000000000..c4c1b07a0cfc
--- /dev/null
+++ b/devel/py-clikit/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= clikit
+PORTVERSION= 0.4.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utilities to build beautiful and testable command line interfaces
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PY_ENUM34} \
+ ${PYTHON_PKGNAMEPREFIX}pastel>=0.1.0:devel/py-pastel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pylev>=1.3<2.0:devel/py-pylev@${PY_FLAVOR} \
+ ${PY_TYPING}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>