aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-dialog3
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-dialog3')
-rw-r--r--devel/py-dialog3/Makefile34
-rw-r--r--devel/py-dialog3/distinfo3
-rw-r--r--devel/py-dialog3/files/patch-dialog.py11
-rw-r--r--devel/py-dialog3/files/patch-doc_intro_example.py11
-rw-r--r--devel/py-dialog3/files/patch-doc_intro_intro.rst20
-rw-r--r--devel/py-dialog3/files/patch-examples_demo.py11
-rw-r--r--devel/py-dialog3/files/patch-examples_simple__example.py11
-rw-r--r--devel/py-dialog3/files/patch-examples_with-autowidgetsize_demo.py11
-rw-r--r--devel/py-dialog3/files/patch-examples_with-autowidgetsize_simple__example.py11
-rw-r--r--devel/py-dialog3/pkg-descr7
10 files changed, 130 insertions, 0 deletions
diff --git a/devel/py-dialog3/Makefile b/devel/py-dialog3/Makefile
new file mode 100644
index 000000000000..7cf2af2c1337
--- /dev/null
+++ b/devel/py-dialog3/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= dialog
+PORTVERSION= 3.4.0
+CATEGORIES= devel python
+MASTER_SITES= SF/python${PORTNAME}/python${PORTNAME}/${PORTVERSION} \
+ LOCAL/jkim
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+DISTNAME= python3-pythondialog-${PORTVERSION}
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Python 3 interface to dialog(3)
+
+LICENSE= LGPL20
+
+RUN_DEPENDS= cdialog:devel/cdialog
+
+USES= python:3.6 tar:bz2
+USE_PYTHON= autoplist concurrent distutils pythonprefix
+PYDISTUTILS_PKGNAME= python${PORTNAME}
+
+WRKSRC= "${WRKDIR}/${DISTNAME:C/^python3-//}"
+
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/ && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR} "! -name *\.orig"
+
+.include <bsd.port.mk>
diff --git a/devel/py-dialog3/distinfo b/devel/py-dialog3/distinfo
new file mode 100644
index 000000000000..f11d25663d38
--- /dev/null
+++ b/devel/py-dialog3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568933548
+SHA256 (python3-pythondialog-3.4.0.tar.bz2) = 019cdbffe3f61d32d6fb158ce48a767478af2aac2f31fb40460b39aefae604fe
+SIZE (python3-pythondialog-3.4.0.tar.bz2) = 1415324
diff --git a/devel/py-dialog3/files/patch-dialog.py b/devel/py-dialog3/files/patch-dialog.py
new file mode 100644
index 000000000000..70468980840f
--- /dev/null
+++ b/devel/py-dialog3/files/patch-dialog.py
@@ -0,0 +1,11 @@
+--- dialog.py.orig 2016-05-07 16:38:28 UTC
++++ dialog.py
+@@ -878,7 +878,7 @@ class Dialog:
+ # wants to know the (integer) error exit status, here it is...
+ return self._DIALOG_ERROR
+
+- def __init__(self, dialog="dialog", DIALOGRC=None,
++ def __init__(self, dialog="cdialog", DIALOGRC=None,
+ compat="dialog", use_stdout=None, *, autowidgetsize=False,
+ pass_args_via_file=None):
+ """Constructor for :class:`Dialog` instances.
diff --git a/devel/py-dialog3/files/patch-doc_intro_example.py b/devel/py-dialog3/files/patch-doc_intro_example.py
new file mode 100644
index 000000000000..ffab20ef4e3e
--- /dev/null
+++ b/devel/py-dialog3/files/patch-doc_intro_example.py
@@ -0,0 +1,11 @@
+--- doc/intro/example.py.orig 2015-04-04 09:43:57 UTC
++++ doc/intro/example.py
+@@ -35,7 +35,7 @@ from dialog import Dialog
+ # This is almost always a good thing to do at the beginning of your programs.
+ locale.setlocale(locale.LC_ALL, '')
+
+-d = Dialog(dialog="dialog")
++d = Dialog(dialog="cdialog")
+
+ button_names = {d.OK: "OK",
+ d.CANCEL: "Cancel",
diff --git a/devel/py-dialog3/files/patch-doc_intro_intro.rst b/devel/py-dialog3/files/patch-doc_intro_intro.rst
new file mode 100644
index 000000000000..ad24f4c8e03f
--- /dev/null
+++ b/devel/py-dialog3/files/patch-doc_intro_intro.rst
@@ -0,0 +1,20 @@
+--- doc/intro/intro.rst.orig 2015-04-04 09:43:57 UTC
++++ doc/intro/intro.rst
+@@ -8,7 +8,7 @@ A minimal program using pythondialog starts with the c
+
+ from dialog import Dialog
+
+- d = Dialog(dialog="dialog")
++ d = Dialog(dialog="cdialog")
+
+ The *dialog* parameter indicates the executable to use to invoke the backend
+ (which must be compatible with dialog_). For instance, one might use something
+@@ -181,7 +181,7 @@ improve readability, we obtain the code for our exampl
+ # This is almost always a good thing to do at the beginning of your programs.
+ locale.setlocale(locale.LC_ALL, '')
+
+- d = Dialog(dialog="dialog")
++ d = Dialog(dialog="cdialog")
+
+ button_names = {d.OK: "OK",
+ d.CANCEL: "Cancel",
diff --git a/devel/py-dialog3/files/patch-examples_demo.py b/devel/py-dialog3/files/patch-examples_demo.py
new file mode 100644
index 000000000000..95e478d20afe
--- /dev/null
+++ b/devel/py-dialog3/files/patch-examples_demo.py
@@ -0,0 +1,11 @@
+--- examples/demo.py.orig 2016-05-07 16:38:28 UTC
++++ examples/demo.py
+@@ -335,7 +335,7 @@ class MyApp:
+ # If you want to use Xdialog (pathnames are also OK for the 'dialog'
+ # argument), you can use:
+ # dialog.Dialog(dialog="Xdialog", compat="Xdialog")
+- self.Dialog_instance = dialog.Dialog(dialog="dialog")
++ self.Dialog_instance = dialog.Dialog(dialog="cdialog")
+ # See the module docstring at the top of the file to understand the
+ # purpose of MyDialog.
+ d = MyDialog(self.Dialog_instance)
diff --git a/devel/py-dialog3/files/patch-examples_simple__example.py b/devel/py-dialog3/files/patch-examples_simple__example.py
new file mode 100644
index 000000000000..e2ed1d8432eb
--- /dev/null
+++ b/devel/py-dialog3/files/patch-examples_simple__example.py
@@ -0,0 +1,11 @@
+--- examples/simple_example.py.orig 2016-05-07 16:38:28 UTC
++++ examples/simple_example.py
+@@ -13,7 +13,7 @@ from dialog import Dialog
+ locale.setlocale(locale.LC_ALL, '')
+
+ # Initialize a dialog.Dialog instance
+-d = Dialog(dialog="dialog")
++d = Dialog(dialog="cdialog")
+ d.set_background_title("A Simple Example")
+
+
diff --git a/devel/py-dialog3/files/patch-examples_with-autowidgetsize_demo.py b/devel/py-dialog3/files/patch-examples_with-autowidgetsize_demo.py
new file mode 100644
index 000000000000..9c76a11f0fea
--- /dev/null
+++ b/devel/py-dialog3/files/patch-examples_with-autowidgetsize_demo.py
@@ -0,0 +1,11 @@
+--- examples/with-autowidgetsize/demo.py.orig 2016-05-07 16:38:28 UTC
++++ examples/with-autowidgetsize/demo.py
+@@ -340,7 +340,7 @@ class MyApp:
+ # widget-producing methods behave as if width=0, height=0, etc. had
+ # been passed, except where these parameters are explicitely specified
+ # with different values.
+- self.Dialog_instance = dialog.Dialog(dialog="dialog",
++ self.Dialog_instance = dialog.Dialog(dialog="cdialog",
+ autowidgetsize=True)
+ # See the module docstring at the top of the file to understand the
+ # purpose of MyDialog.
diff --git a/devel/py-dialog3/files/patch-examples_with-autowidgetsize_simple__example.py b/devel/py-dialog3/files/patch-examples_with-autowidgetsize_simple__example.py
new file mode 100644
index 000000000000..c93b4dc10dc6
--- /dev/null
+++ b/devel/py-dialog3/files/patch-examples_with-autowidgetsize_simple__example.py
@@ -0,0 +1,11 @@
+--- examples/with-autowidgetsize/simple_example.py.orig 2016-05-07 16:38:28 UTC
++++ examples/with-autowidgetsize/simple_example.py
+@@ -17,7 +17,7 @@ locale.setlocale(locale.LC_ALL, '')
+ # With the 'autowidgetsize' option enabled, pythondialog's widget-producing
+ # methods behave as if width=0, height=0, etc. had been passed, except where
+ # these parameters are explicitely specified with different values.
+-d = Dialog(dialog="dialog", autowidgetsize=True)
++d = Dialog(dialog="cdialog", autowidgetsize=True)
+ d.set_background_title("A Simple Example")
+
+
diff --git a/devel/py-dialog3/pkg-descr b/devel/py-dialog3/pkg-descr
new file mode 100644
index 000000000000..857b2b6be28e
--- /dev/null
+++ b/devel/py-dialog3/pkg-descr
@@ -0,0 +1,7 @@
+pythondialog 3 is a Python 3 wrapper for the dialog utility originally
+written by Savio Lam, and later rewritten by Thomas E. Dickey. Its purpose
+is to provide an easy to use, pythonic and comprehensive Python 3 interface
+to dialog. This allows one to make simple text-mode user interfaces on
+Unix-like systems.
+
+WWW: http://pythondialog.sourceforge.net/