aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-gitdb2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-gitdb2/Makefile')
-rw-r--r--devel/py-gitdb2/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/py-gitdb2/Makefile b/devel/py-gitdb2/Makefile
new file mode 100644
index 000000000000..a7784d445557
--- /dev/null
+++ b/devel/py-gitdb2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gitdb2
+PORTVERSION= 2.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Git Object Database
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}smmap2>=2.0.0:devel/py-smmap2
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.mk>