aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-htmlkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-htmlkit/Makefile')
-rw-r--r--devel/py-htmlkit/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/py-htmlkit/Makefile b/devel/py-htmlkit/Makefile
new file mode 100644
index 000000000000..eb1e5a4b16de
--- /dev/null
+++ b/devel/py-htmlkit/Makefile
@@ -0,0 +1,35 @@
+# Ports collection Makefile for: py-HtmlKit
+# Date created: 06/08/2000
+# Whom: kbyanc@posi.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= HtmlKit
+PORTVERSION= 1.0
+CATEGORIES= devel python www
+MASTER_SITES= http://www.dekorte.com/Software/Python/HtmlKit/Download/
+PKGNAMEPREFIX= py-
+DISTNAME= HtmlKit
+EXTRACT_SUFX= .tar
+
+MAINTAINER= kbyanc@posi.net
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/python1.5/site-packages
+ @${MKDIR} ${PREFIX}/lib/python1.5/site-packages/HtmlKit/
+ @for i in ${WRKSRC}/*.py; do \
+ ${INSTALL_DATA} $$i ${PREFIX}/lib/python1.5/site-packages/HtmlKit; \
+ done
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/HtmlKit
+ @for i in ${WRKSRC}/Documentation/*; do \
+ ${INSTALL_DATA} $$i ${PREFIX}/share/doc/HtmlKit; \
+ done
+.endif
+
+.include <bsd.port.mk>