aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-htmlkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-htmlkit/Makefile')
-rw-r--r--devel/py-htmlkit/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/py-htmlkit/Makefile b/devel/py-htmlkit/Makefile
index 3f3b859d9d80..6d1dd003ab2c 100644
--- a/devel/py-htmlkit/Makefile
+++ b/devel/py-htmlkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HtmlKit
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel python www
MASTER_SITES= http://www.dekorte.com/Software/Python/HtmlKit/Download/
PKGNAMEPREFIX= py-
@@ -14,16 +15,16 @@ DISTNAME= HtmlKit
MAINTAINER= kbyanc@posi.net
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
-
+USE_PYTHON= yes
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
NO_BUILD= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/python1.5/site-packages
- @${MKDIR} ${PREFIX}/lib/python1.5/site-packages/HtmlKit/
+ @${MKDIR} ${PYTHON_SITELIBDIR}/HtmlKit
@for i in ${WRKSRC}/*.py; do \
- ${INSTALL_DATA} $$i ${PREFIX}/lib/python1.5/site-packages/HtmlKit; \
+ ${INSTALL_DATA} $$i ${PYTHON_SITELIBDIR}/HtmlKit; \
done
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PYTHON_SITELIBDIR}/HtmlKit
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/HtmlKit
@for i in ${WRKSRC}/Documentation/*; do \