aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-icu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-icu/Makefile')
-rw-r--r--devel/py-icu/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
index 9d3027e72c1b..639dc34cc5bb 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-icu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= icu
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/P/PyICU
@@ -14,9 +14,8 @@ MAINTAINER= bland@FreeBSD.org
COMMENT= Python extension wrapping IBM's ICU C++ API
USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= PyICU
-PYEASYINSTALL_ARCHDEP= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
MAKE_ENV+= \
PYICU_INCLUDES="${PREFIX}/include" \
@@ -24,6 +23,6 @@ MAKE_ENV+= \
PYICU_LFLAGS="-L${PREFIX}/lib" \
PYICU_LIBRARIES="icui18n:icuuc:icudata"
-LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= libicudata.so:${PORTSDIR}/devel/icu
.include <bsd.port.mk>