aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-pudb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pudb/Makefile')
-rw-r--r--devel/py-pudb/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-pudb/Makefile b/devel/py-pudb/Makefile
new file mode 100644
index 000000000000..fe0a46d0638a
--- /dev/null
+++ b/devel/py-pudb/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-pudb
+# Date created: 2009-11-01
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pudb
+PORTVERSION= 0.92.13
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A full-screen, console-based Python debugger
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:${PORTSDIR}/textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}urwid>0:${PORTSDIR}/devel/py-urwid
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>