aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-reedsolo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-reedsolo/Makefile')
-rw-r--r--devel/py-reedsolo/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-reedsolo/Makefile b/devel/py-reedsolo/Makefile
new file mode 100644
index 000000000000..bd5a92166c56
--- /dev/null
+++ b/devel/py-reedsolo/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= reedsolo
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.4
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Pure-Python Reed Solomon encoder/decoder
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_GITHUB= yes
+USE_PYTHON= autoplist cython distutils
+
+GH_ACCOUNT= tomerfiliba
+GH_PROJECT= reedsolomon
+TEST_ENV+= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+do-test:
+ @cd ${TEST_WRKSRC} && \
+ ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} --with-coverage -d -v
+
+.include <bsd.port.mk>
/a>linimon2005-12-021-1/+1 | * - Add WANT_STATIC_BASH knob.flz2005-11-301-0/+10 | | | | | | PR: ports/81795 Submitted by: Bjarne Koenig <bkoenig@cs.tu-berlin.de> Approved by: maintainer timeout (5 months) * - Style: ports@freebsd.org -> ports@FreeBSD.orgpav2005-11-261-1/+1 | * - Add SHA256 checksums to my portssergei2005-11-251-0/+2 | * - Add SHA256pav2005-11-249-0/+9 | * Add a missing man page to MAN1.knu2005-11-181-1/+2 | | | | Noticed by: kris * Update to 0.95edwin2005-11-153-7/+6 | * Update to 2.07bknu2005-11-144-31/+20 | | | | Turn ADJTTY off by default. * - add SHA checksumdinoex2005-11-131-0/+1 | * Iron Bars Shell is a restricted Unix shell. The user can not step out of, norpav2005-11-127-0/+91 | | | | | | | | | access files outside the home directory. It is written in C for Linux. No libraries used. It is small, fast, secure. Two ascii configuration files for more control. PR: ports/88351 Submitted by: Vaida Bogdan <vaidab@phenix.rootshell.be> * With portmgr hat on, reset maintainership of knu's ports since he haslinimon2005-11-112-2/+2 | | | | been inactive more than 6 months. We hope to see him back sometime. * - Add SHA256garga2005-11-082-0/+2 | * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-051-0/+1 | * Fix ${name:?word} substitution. Bump PORTREVISION.tg2005-11-022-0/+12 | | | | | Submitted by: Marc Olzheim (marcolz at stack dot nl) Obtained from: OpenBSD PR user/4023 * Use groups to prevent trying to fetch the wrong patches from thefenner2005-10-161-3/+3 | | | | | | wrong sites. Approved by: obrien (MAINTAINER) * Provide accurate COMMENT and pkg-descrgarga2005-10-152-2/+5 | | | | Submitted by: maintainer by email * Add tcsh-bofh 6.12.00, patch tcsh to providing true BOFH logfunctions.garga2005-10-144-0/+39 | | | | | PR: ports/87394 Submitted by: Krzysztof Kowalewski <pyzmen@kam.pl> * search.cpan.org redirect reduction canonicalization project, pass 3:fenner2005-09-232-2/+2 | | | | | | | | Refer to all modules using their /dist/Foo/ path instead of via the mishmash of old author path, new author path, module documentation, etc. These are mostly stragglers that should have been caught in pass 2. This pass brought to you by Bill's 102-degree fever during pass 2. * Unbreak on 4.x: gnatbind does not support -D_THREAD_SAFE.thierry2005-09-121-2/+37 | | | | Reported by: pointyhat via Kris * - Update to 2.0.3jylefort2005-09-065-50/+25 | | | | - Reformat the Makefile * - Stop adding rzsh (restricted zsh) to /etc/shells [1]:sergei2005-09-062-6/+36 | | | | | | | | | | | | | | | | | | | | | rzsh(1) is the restricted version of zsh(1), with various things disabled so as to provide a strictly limited access to the system. A user with a shell in /etc/shells can use chsh(1) to change their shell, can use FTP, can use other file-transfer services, etc. Thus, adding rzsh to /etc/shells could be a security risk in certain configurations. - zsh-mime-setup is set up to look for /etc/{mime.types,mailcap}. Neither of them should exist on a stock FreeBSD system. Teach it to look in ${LOCALBASE}/etc instead. [2] - Zsh completion doesn't know about bsdtar(1) achievements: it won't complete to foo.tar.gz if you just enter 'tar xf foo^D'. Teach zsh completion about this and other formats supported by bsdtar(1). NOTE: This is only applicable to FreeBSD 5.3-RELEASE or newer, where bsdtar(1) replaced GNU tar(1) in the base system. - Bump PORTREVISION PR: ports/82066 [2], ports/83023 [3] Submitted by: Phil Pennock <pdp@nl.demon.net> [1] Ulrich Spoerlein <q@galgenberg.net> [2] [3] * There is more than 12 packages now.thierry2005-09-031-1/+1 | | | | Noted by: Ken Burtch <ken (at) pegasoft.ca> (author) * Upgrade to 1.0.3.thierry2005-09-023-6/+70 | * - Re-add patch-configure (removed by mistake) to fix the build on the cluster;thierry2005-09-023-2/+28 | | | | | | - handle ADACFLAGS. Note: update to 1.0.3 is in progress. * Remove mastersite which has gone away.linimon2005-09-011-1/+0 | | | | Approved by: maintainer * Remove ftp.rge.com from MASTER_SITES.tg2005-08-301-2/+1 | * - Retire shells/zsh-devel in favor of shells/zsh:sergei2005-08-295-772/+0 | | | | | The development version of Zsh is no longer being released. Interested parties can always check out Zsh from SourceForge.net CVS. * Upgrade to 1.0.2.thierry2005-08-287-47/+32 | * [1]:jylefort2005-07-308-124/+58 | | | | | | | | | | | | | - Update to 20050721 - OPTIONSify Moreover: - Improve the FreeBSD integration by fixing paths in the script - Use SUB_FILES=pkg-message [1]: PR: ports/84305 Submitted by: maintainer * Per prior standing request, turn this port over from inactive committerlinimon2005-07-201-1/+1 | | | | | | (eik) to obrien. Hat: portmgr * Change MASTER_SITES to a CPAN address since old is brokengarga2005-07-124-4/+4 | | | | | Approved by: flz (mentor) Reported by: kris * Change MAINTAINER to my @FreeBSD.org accountgarga2005-07-122-2/+2 | | | | Approved by: flz (mentor) * Update to osh-050219 to fix fetchingkris2005-07-112-8/+3 | * Fix svn issue with scponly via ssh+svn://.nork2005-06-201-2/+3 | | | | | Submitted by: Matthias Fechner <idefix@fechner.net> Reviewed by: rushani (maintainer) * Bump PORTREVISION by previous commit.nork2005-06-191-1/+1 | | | | Approved by: rushani (maintainer) * Add support ssh+svn://.nork2005-06-191-0/+9 | | | | | | PR: ports/81889 Submitted by: Matthias Fechner <idefix@fechner.net> Approved by: rushani (maintainer) * - Add itself to /etc/shellspav2005-06-062-1/+13 | | | | | | PR: ports/81257 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> Approved by: maintainer timeout (16 days) * Fix this patch file.obrien2005-05-052-21/+12 | | | | | PR: 69873 Submitted by: Dave Evans <root@hclb.demon.co.uk> * - Change the way used to add/remove the shell on /etc/shells,clsung2005-05-048-24/+84 | | | | | | | | | | use pkg-install and pkg-deinstall (both stoled from shells/bash) to do it. - Remove pre-install section, it's not more needed on this version, because Makefile is created correctly changing Makefile.PL PR: 80583 Submitted by: Renato Botelho (maintainer) * Tweak pkg-descr, break out /etc/shell editing as seperate target, installobrien2005-04-293-13/+231 | | | | | | | examples. Also use the modern nobs bsd.port.mk provides. PR: 30732 Submitted by: Cyrille Lefevre <clefevre@citeweb.net> * - Use MAKE_ARGSvs2005-04-262-22/+1 | | | | - Don't invoke install-info twice when using INFO * Update to version 1.0136krion2005-04-212-3/+3 | | | | | PR: ports/80210 Submitted by: Ports Fury * - Update to 4.2.5sergei2005-04-203-15/+20 | | | | | | | - Update MASTER_SITES based on the list at http://www.zsh.org/ PR: ports/79708 Submitted by: KIMURA Yasuhiro <yasu@utahime.org> * - It was not installing on FreeBSD 4.x with perl 5.00503.leeym2005-04-206-0/+40 | | | | | | | | - Rename patch-aa to reflect which file is patched. - update /etc/shells in pkg-plist for package PR: 80104 Submitted by: Renato Botelho <freebsd@galle.com.br> (maintainer) * - Update to 1.8sergei2005-04-198-96/+202 | | | | | | | | | | - Unbreak - Remove gratuitous use of REINPLACE - Add $FreeBSD$ on pkg-plist - Assign maintainership to the submitter PR: ports/79623 Submitted by: Renato Botelho <freebsd@galle.com.br> * - Update to 4.1leeym2005-04-143-16/+4 | | | | | PR: 79859 Submitted by: rushani * Change my MAINTAINER email address to jylefort@FreeBSD.orgjylefort2005-04-132-2/+2 | | | | Approved by: adamw (mentor) * CVS really does need a better way of backing out a commit composing aobrien2005-04-121-3/+2 | | | | set of files... * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-123-3/+4 | | | | after 5.4-RELEASE. * Very sorry for a local change that made it into the last commit.obrien2005-04-111-2/+1 | * Assist getting more ports working on AMD64 by obeying theobrien2005-04-113-4/+5 | | | | Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'. * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-0/+1 | * Remove references to ports recently deleted.kris2005-02-211-3/+0 | * As previously announced, remove ports that have reached their expiry date,kris2005-02-1929-675/+0 | | | | and the handful of ports that depended on them. * BROKEN: Incomplete pkg-plistkris2005-02-122-0/+4 | * - Update to 4.2.4sergei2005-02-072-5/+5 | | | | | PR: ports/77172 Submitted by: KIMURA Yasuhiro <yasu@utahime.org> * Update to 2005-02-02vs2005-02-042-5/+5 | | | | | PR: ports/77072 Submitted by: Joey Kelsey (maintainer) * Use USE_PGSQLerwin2005-01-311-3/+1 | | | | Forgotten by: girgen * Update to version 2.2.3 to fix security vulnerability.simon2005-01-262-3/+3 | | | | | | Security: http://vuxml.FreeBSD.org/f11b219a-44b6-11d9-ae2f-021106004fd6.html With hat: secteam Approved by: maintainer timeout (security; 2 days), erwin (mentor) * Remove the test for /dev/dsp during configure, it does not affect thethierry2005-01-261-0/+13 | | | | | | package build. Reported by: Kris via pointyhat. * - Update to 4.2.3sergei2005-01-243-6/+23 | | | | | PR: ports/76268 Submitted by: KIMURA Yasuhiro <yasu@utahime.org> * Add bush 1.0.1, the Business Shell.thierry2005-01-247-0/+177 | * - Update to 1.0.2pav2005-01-20