aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-ro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-ro/Makefile')
-rw-r--r--devel/py-ro/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/py-ro/Makefile b/devel/py-ro/Makefile
index 26468cbdd035..b2df501d1250 100644
--- a/devel/py-ro/Makefile
+++ b/devel/py-ro/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ro
-PORTVERSION= 3.7
+PORTVERSION= 3.8.1
CATEGORIES= devel python
MASTER_SITES= SF
MASTER_SITE_SUBDIR= pyro
@@ -21,19 +21,21 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Pyro
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-patch:
${ECHO} -e 'install-scripts=${PREFIX}/bin\n' \
'\n[install-options]\nunattended=1' >> ${WRKSRC}/setup.cfg
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+ @(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>