aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-setuptools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-setuptools/Makefile')
-rw-r--r--devel/py-setuptools/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-setuptools/Makefile b/devel/py-setuptools/Makefile
new file mode 100644
index 000000000000..4126b322b736
--- /dev/null
+++ b/devel/py-setuptools/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-setuptools
+# Date created: 2005-11-21
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= setuptools
+PORTVERSION= 0.6a8
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/s/setuptools/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Download, build, install, upgrade, and uninstall Python packages
+
+USE_ZIP= yes
+DIST_SUBDIR= python
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>