aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-utils/Makefile')
-rw-r--r--devel/py-utils/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/py-utils/Makefile b/devel/py-utils/Makefile
new file mode 100644
index 000000000000..7d6bd0a132af
--- /dev/null
+++ b/devel/py-utils/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-utils
+# Date created: 16 March 2006
+# Whom: Daniel Bretoi
+#
+# $FreeBSD$
+#
+
+PORTNAME= utils
+PORTVERSION= 0.2.5
+CATEGORIES= devel
+MASTER_SITES= http://www.voidspace.org.uk/cgi-bin/voidspace/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= downman.py?file=pythonutils-${PORTVERSION}
+
+MAINTAINER= daniel@netwalk.org
+COMMENT= General utility modules that simplify common programming in Python
+
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS=yes
+WRKSRC= ${WRKDIR}/pythonutils-${PORTVERSION}
+USE_ZIP= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>