aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-zope.interface/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-zope.interface/Makefile')
-rw-r--r--devel/py-zope.interface/Makefile24
1 files changed, 23 insertions, 1 deletions
diff --git a/devel/py-zope.interface/Makefile b/devel/py-zope.interface/Makefile
index d61ba70e7097..1b00917a7d75 100644
--- a/devel/py-zope.interface/Makefile
+++ b/devel/py-zope.interface/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zopeInterface
PORTVERSION= 3.3.0
+PORTREVISION= 1
CATEGORIES= devel zope python
MASTER_SITES= http://www.zope.org/Products/ZopeInterface/${PORTVERSION}/ \
http://cheeseshop.python.org/packages/source/z/zope.interface/
@@ -16,7 +17,28 @@ DISTNAME= zope.interface-${PORTVERSION}
MAINTAINER= neal@nelson.name
COMMENT= Zope.interface package from Zope 3
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MANUAL_PACKAGE_BUILD=Doesn't build in tinderbox environment
+
USE_PYTHON= 2.2+
USE_PYDISTUTILS= yes
-.include <bsd.port.mk>
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYZOPEINTERFACE_EGG}
+
+PYZOPEINTERFACE_EGG= zope.interface-${PORTVERSION}-py${PYTHON_VER}-${OPSYS:L}-${OSRELEASE}-${ARCH}.egg
+
+PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PYZOPEINTERFACE_EGG=${PYZOPEINTERFACE_EGG} \
+ PYZOPEINTERFACE_EGG_VER="zope.interface==${PORTVERSION}"
+
+.include <bsd.port.pre.mk>
+
+OSRELEASE!= ${DESTDIR}/usr/bin/uname -r
+
+.include <bsd.port.post.mk>